当前位置:8090st.com >系统管理 > 查看文章
阿里云优惠码

20150519154939

1、安装httpd-2.2.27./configure 的时候报错如下
checking for void pointerlength… yes configure: error: Size of “void *” is less than size of”long”

解决方法vi configure
if test”$ap_cv_void_ptr_lt_long” =”yes”; then
as_fn_error $? “Size of \”void*\” is less than size of \”long\”” “$LINENO” 5
改为if test”$ap_cv_void_ptr_lt_long” != “yes”; then
as_fn_error $? “Size of \”void*\” is less than size of \”long\”” “$LINENO” 5
保存重新编译

2、linux下安装安装pcre-8.32

./configure –prefix=/usr/local/pcre 出现以下错误
configure: error: You need a C++ compiler for C++ support
正解

yum install -y gcc gcc-c++
 

3、如果在安装apache的时候入到 error: mod_deflate has beenrequested but can not be built due to prerequisite failures的错误,那是没有安装zlib包。centos下可以采用yum install zlib-devel, ubuntu下可以采用apt-get install zlib1g-dev.

4、在编译apache的过程中出现如下错误:
no SSL-C headers found
configure: error: …No recognized SSL/TLS toolkit detected
解决办法:
安装openssl-devel

5、安装apache报错
代码如下:
rotatelogs.o: In function post_rotate’:
rotatelogs.c:(.text+0x5ed): undefined reference to apr_file_link’
collect2: ld returned 1 exit status
make[2]: *** [rotatelogs] Error 1
make[2]: Leaving directory /root/src/httpd-2.4.2/support’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory /root/src/httpd-2.4.2/support’
make: *** [all-recursive] Error 1
这些是因为没apr的包
有2个解决方法:
第一种解决办法:
.代码如下:

yum remove “apr*”
wget http://ftp.jaist.ac.jp/pub/apache/apr/apr-1.4.6.tar.gz
tar xzf apr-1.4.6.tar.gz
cd apr-1.4.6
./configure ; make ; make install
wget http://ftp.jaist.ac.jp/pub/apache/apr/apr-util-1.4.1.tar.gz
tar zxvf apr-util-1.4.1.tar.gz
cd apr-util-1.4.1
./configure –with-apr=/usr/local/apr
yum install -y pcre-devel lua-devel libxml2-devel
 

第二种解决办法:
下载arp的包以后 cp到httpd的文件夹
.代码如下:

cp -r apr-1.4.6 httpd-2.4.2/srclib/apr
cp -r apr-util-1.4.1 httpd-2.4.2/srclib/apr-util
 [/code"]
就可以解决了
第二个常见的错误这种只有mini安装会出现 一般大部分菜鸟都不会安装devel的包
.代码如下:
checking for OpenSSL version >= 0.9.7… FAILED
configure: WARNING: OpenSSL version is too old
no
checking whether to enable mod_ssl… configure: error:mod_ssl has been requested but can not be built due to prerequisite failures
解决办法
.代码如下:
 
yum install openssl-devel
yum update openssl
 
本文链接:https://www.8090st.com/apache-bug-the-problem.html 转载请注明出处.
如果喜欢:点此订阅本站
相关文章
为您推荐
各种观点
暂时还木有人评论,坐等沙发!
发表评论

您必须 [ 登录 ] 才能发表留言!